やっつけで書き上げた。でももうちょいキレイにかけるとおもう。

<?php
$agent = getenv(HTTP_USER_AGENT);
print <p>$agent</p>."
";
if ($pos = strpos($agent, MSIE)) {
	$name = MSIE;
	$ver = substr($agent, $pos+5, strpos($agent, ;, $pos) - $pos - 5);
	// メジャーバージョンだけでいいなら↓でもok(てきとう)
	// $ver = substr($agent, $pos+5, 1);
} else if ($pos = strpos($agent, Firefox)) {
	$name = Firefox;
	$ver = substr($agent, $pos+8, strpos($agent,  , $pos) - $pos - 8);
} else if ($pos = strpos($agent, Safari)) {
	$name = Safari;
	$ver = substr( strrchr($agent, Safari), 7);

	if ($pos = strpos($agent, Chrome)) {
		$name = Chrome;
		$ver = substr($agent, $pos+7, strpos($agent,  , $pos) - $pos - 7);
	}
}
else if (ereg(Opera, $agent)) {
	$name = Opera;
	$pos = strpos($agent, Opera);
	$ver = substr($agent, $pos+6, strpos($agent,  , $pos) - $pos - 6);
}
else {
	$name = Unknown;
	$ver = Unknown;
}

print $name . /  .$ver . <br>;
?>

右上のブログパーツでつかうつもりなんだけど、あとはブラウザの最新バージョンを拾うにはどうしたら良いか検討せねばー